Skip to content

← Actionable
High, CVSS 7.5

openssl-src subject to Invalid pointer dereference in d2i_PKCS7 functions

CVE-2023-0216GHSA-29xx-hcv2-c4cp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-src 300.0.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io openssl-src

    Affected
    >= 300.0.0, < 300.0.12
    Fixed in
    300.0.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-0216: 1.85% estimated exploitation activity in the next 30 days; percentile 79.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An invalid pointer dereference on read can be triggered when an application tries to load malformed PKCS7 data with the d2iPKCS7(), d2iPKCS7bio() or d2iPKCS7fp() functions. The result of the dereference is an application crash which could lead to a denial of service attack. The TLS implementation in OpenSSL does not call this function however third party applications might call these functions on untrusted data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-29xx-hcv2-c4cp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-0216

Advisory: openssl-src subject to Invalid pointer dereference in `d2i_PKCS7` functions
IDs: CVE-2023-0216, GHSA-29xx-hcv2-c4cp
Record: https://patchnext.com/advisories/cve-2023-0216 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openssl-src 300.0.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io openssl-src: affected >= 300.0.0, < 300.0.12; fixed in 300.0.12

## Suggested inspection (read-only)
- crates.io openssl-src: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openssl-src.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-29xx-hcv2-c4cp (GitHub-reviewed advisory GHSA-29xx-hcv2-c4cp lists affected ranges: crates.io openssl-src >=300.0.0 <300.0.12)

Commands are suggestions: review each one before running it.

Loading voting…