Juju controller - Arbitrary file reading vulnerability
CVE-2023-0092GHSA-x5rv-w9pm-8qp8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/juju/juju 3.0.3, 2.9.38), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.9.22, < 2.9.38>= 3.0.0, < 3.0.3
- Fixed in
- 3.0.3, 2.9.38
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x5rv-w9pm-8qp8 lists affected ranges: Go github.com/juju/juju >=2.9.22 =3.0.0 <3.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-0092: 0.63% estimated exploitation activity in the next 30 days; percentile 50.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user who has read access to the juju controller model, may construct a remote request to download an arbitrary file from the controller's filesystem. Patches Patched in juju 2.9.38 and juju 3.0.3 juju/juju#ef803e2 Workarounds Limit read access to the controller model to only trusted users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x5rv-w9pm-8qp8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-0092 Advisory: Juju controller - Arbitrary file reading vulnerability IDs: CVE-2023-0092, GHSA-x5rv-w9pm-8qp8 Record: https://patchnext.com/advisories/cve-2023-0092 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/juju/juju 3.0.3, 2.9.38. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/juju/juju: affected >= 2.9.22, < 2.9.38; >= 3.0.0, < 3.0.3; fixed in 3.0.3, 2.9.38 ## Suggested inspection (read-only) - Go github.com/juju/juju: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/juju/juju. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x5rv-w9pm-8qp8 (GitHub-reviewed advisory GHSA-x5rv-w9pm-8qp8 lists affected ranges: Go github.com/juju/juju >=2.9.22 =3.0.0 <3.0.3) Commands are suggestions: review each one before running it.
Loading voting…