Cross-site Scripting in Quarkus
CVE-2023-0044GHSA-c57v-hc7m-8px2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.quarkus:quarkus-vertx-http 2.13.7.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.quarkus:quarkus-vertx-http
- Affected
- < 2.13.7.Final
- Fixed in
- 2.13.7.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c57v-hc7m-8px2 lists affected ranges: Maven io.quarkus:quarkus-vertx-http >=0 <2.13.7.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-0044: 0.55% estimated exploitation activity in the next 30 days; percentile 46.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
If the Quarkus Form Authentication session cookie Path attribute is set to / then a cross-site attack may be initiated which might lead to the Information Disclosure. This attack can be prevented with the Quarkus CSRF Prevention feature.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c57v-hc7m-8px2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-0044 Advisory: Cross-site Scripting in Quarkus IDs: CVE-2023-0044, GHSA-c57v-hc7m-8px2 Record: https://patchnext.com/advisories/cve-2023-0044 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.quarkus:quarkus-vertx-http 2.13.7.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.quarkus:quarkus-vertx-http: affected < 2.13.7.Final; fixed in 2.13.7.Final ## Suggested inspection (read-only) - Maven io.quarkus:quarkus-vertx-http: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.quarkus:quarkus-vertx-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c57v-hc7m-8px2 (GitHub-reviewed advisory GHSA-c57v-hc7m-8px2 lists affected ranges: Maven io.quarkus:quarkus-vertx-http >=0 <2.13.7.Final) Commands are suggestions: review each one before running it.
Loading voting…