Cross-site Scripting in UDX Stateless Media Plugin
CVE-2022-4905GHSA-9j2p-8qqf-h55c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wpcloud/wp-stateless 3.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wpcloud/wp-stateless
- Affected
- < 3.2.0
- Fixed in
- 3.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9j2p-8qqf-h55c lists affected ranges: Packagist wpcloud/wp-stateless >=0 <3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-4905: 0.66% estimated exploitation activity in the next 30 days; percentile 51.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in UDX Stateless Media Plugin 3.1.1. It has been declared as problematic. This vulnerability affects the function setupwizardinterface of the file lib/classes/class-settings.php. The manipulation of the argument settings leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 3.2.0 is able to address this issue. The name of the patch is 6aee7ae0b0beeb2232ce6e1c82aa7e2041ae151a. It is recommended to upgrade the affected component. VDB-220750 is the identifier assigned to this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9j2p-8qqf-h55c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-4905 Advisory: Cross-site Scripting in UDX Stateless Media Plugin IDs: CVE-2022-4905, GHSA-9j2p-8qqf-h55c Record: https://patchnext.com/advisories/cve-2022-4905 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wpcloud/wp-stateless 3.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wpcloud/wp-stateless: affected < 3.2.0; fixed in 3.2.0 ## Suggested inspection (read-only) - Packagist wpcloud/wp-stateless: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wpcloud/wp-stateless. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9j2p-8qqf-h55c (GitHub-reviewed advisory GHSA-9j2p-8qqf-h55c lists affected ranges: Packagist wpcloud/wp-stateless >=0 <3.2.0) Commands are suggestions: review each one before running it.
Loading voting…