Skip to content

← Actionable
Medium, CVSS 4.3

Sisimai Inefficient Regular Expression Complexity vulnerability

CVE-2022-4891GHSA-vm74-j4wq-82xj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sisimai 4.25.14p12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems sisimai

    Affected
    < 4.25.14p12
    Fixed in
    4.25.14p12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2022-4891: 1.39% estimated exploitation activity in the next 30 days; percentile 72.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability has been found in Sisimai up to 4.25.14p11 and classified as problematic. This vulnerability affects the function toplain of the file lib/sisimai/string.rb. The manipulation leads to inefficient regular expression complexity. The exploit has been disclosed to the public and may be used. Upgrading to version 4.25.14p12 is able to address this issue. The name of the patch is 51fe2e6521c9c02b421b383943dc9e4bbbe65d4e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218452.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vm74-j4wq-82xj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-4891

Advisory: Sisimai Inefficient Regular Expression Complexity vulnerability
IDs: CVE-2022-4891, GHSA-vm74-j4wq-82xj
Record: https://patchnext.com/advisories/cve-2022-4891 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sisimai 4.25.14p12. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems sisimai: affected < 4.25.14p12; fixed in 4.25.14p12

## Suggested inspection (read-only)
- RubyGems sisimai: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sisimai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vm74-j4wq-82xj (GitHub-reviewed advisory GHSA-vm74-j4wq-82xj lists affected ranges: RubyGems sisimai >=0 <4.25.14p12)

Commands are suggestions: review each one before running it.

Loading voting…