Stored XSS vulnerability in Jenkins Checkmarx Plugin
CVE-2022-46684GHSA-p86x-75j8-w4xh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.checkmarx.jenkins:checkmarx 2022.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.checkmarx.jenkins:checkmarx
- Affected
- <= 2022.3.3
- Fixed in
- 2022.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p86x-75j8-w4xh lists affected ranges: Maven com.checkmarx.jenkins:checkmarx >=0 <=2022.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-46684: 0.49% estimated exploitation activity in the next 30 days; percentile 41.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
heckmarx Plugin processes Checkmarx service API responses and generates HTML reports from them for rendering on the Jenkins UI. Checkmarx Plugin 2022.3.3 and earlier does not escape values returned from the Checkmarx service API before inserting them into HTML reports. This results in a stored cross-site scripting (XSS) vulnerability. While Jenkins users without Overall/Administer permission are not allowed to configure the URL to the Checkmarx service, this could still be exploited via man-in-the-middle attacks. Checkmarx Plugin 2022.4.3 escapes values returned from the Checkmarx service API before inserting them into HTML reports.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p86x-75j8-w4xh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-46684 Advisory: Stored XSS vulnerability in Jenkins Checkmarx Plugin IDs: CVE-2022-46684, GHSA-p86x-75j8-w4xh Record: https://patchnext.com/advisories/cve-2022-46684 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.checkmarx.jenkins:checkmarx 2022.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.checkmarx.jenkins:checkmarx: affected <= 2022.3.3; fixed in 2022.4.3 ## Suggested inspection (read-only) - Maven com.checkmarx.jenkins:checkmarx: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.checkmarx.jenkins:checkmarx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p86x-75j8-w4xh (GitHub-reviewed advisory GHSA-p86x-75j8-w4xh lists affected ranges: Maven com.checkmarx.jenkins:checkmarx >=0 <=2022.3.3) Commands are suggestions: review each one before running it.
Loading voting…