Apache CXF vulnerable to Exposure of Sensitive Information
CVE-2022-46363GHSA-3w37-5p3p-jv92
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.cxf:cxf-core 3.5.5, 3.4.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.cxf:cxf-core
- Affected
- < 3.4.10>= 3.5.0, < 3.5.5
- Fixed in
- 3.5.5, 3.4.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3w37-5p3p-jv92 lists affected ranges: Maven org.apache.cxf:cxf-core >=0 =3.5.0 <3.5.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-46363: 1.26% estimated exploitation activity in the next 30 days; percentile 69.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in Apache CXF before versions 3.5.5 and 3.4.10 allows an attacker to perform a remote directory listing or code exfiltration. The vulnerability only applies when the CXFServlet is configured with both the static-resources-list and redirect-query-check attributes. These attributes are not supposed to be used together, and so the vulnerability can only arise if the CXF service is misconfigured.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3w37-5p3p-jv92
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-46363 Advisory: Apache CXF vulnerable to Exposure of Sensitive Information IDs: CVE-2022-46363, GHSA-3w37-5p3p-jv92 Record: https://patchnext.com/advisories/cve-2022-46363 (revision 1, source checked 26 Oct 2026, 16:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.cxf:cxf-core 3.5.5, 3.4.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.cxf:cxf-core: affected < 3.4.10; >= 3.5.0, < 3.5.5; fixed in 3.5.5, 3.4.10 ## Suggested inspection (read-only) - Maven org.apache.cxf:cxf-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.cxf:cxf-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3w37-5p3p-jv92 (GitHub-reviewed advisory GHSA-3w37-5p3p-jv92 lists affected ranges: Maven org.apache.cxf:cxf-core >=0 =3.5.0 <3.5.5) Commands are suggestions: review each one before running it.
Loading voting…