Apache Derby: LDAP injection vulnerability in authenticator
CVE-2022-46337GHSA-rcjc-c4pj-xxrp
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.derby:derby
- Affected
- >= 10.1.1.0, <= 10.1.3.1>= 10.2.1.6, <= 10.2.2.0>= 10.3.1.4, <= 10.3.3.0>= 10.4.1.3, <= 10.4.2.0>= 10.5.1.1, <= 10.5.3.0>= 10.6.1.0, <= 10.6.2.1>= 10.7.1.1, <= 10.7.1.1>= 10.8.1.2, <= 10.8.3.0>= 10.9.1.0, <= 10.9.1.0>= 10.10.1.1, <= 10.10.2.0>= 10.11.1.1, <= 10.11.1.1>= 10.12.1.1, <= 10.12.1.1>= 10.13.1.1, <= 10.13.1.1>= 10.14.2.0, <= 10.14.2.0>= 10.16.1.1, <= 10.16.1.1>= 10.15.1.3, <= 10.15.2.0
- Fixed in
- 10.14.2.1, 10.15.2.1, 10.16.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rcjc-c4pj-xxrp lists affected ranges: Maven org.apache.derby:derby >=10.1.1.0 =10.2.1.6 =10.3.1.4 =10.4.1.3 =10.5.1.1 =10.6.1.0 =10.7.1.1 =10.8.1.2 =10.9.1.0 =10.10.1.1 =10.11.1.1 =10.12.1.1 =10.13.1.1 =10.14.2.0 =10.16.1.1 =10.15.1.3 <=10.15.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-46337: 1.42% estimated exploitation activity in the next 30 days; percentile 72.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A cleverly devised username might bypass LDAP authentication checks. In LDAP-authenticated Derby installations, this could let an attacker fill up the disk by creating junk Derby databases. In LDAP-authenticated Derby installations, this could also allow the attacker to execute malware which was visible to and executable by the account which booted the Derby server. In LDAP-protected databases which weren't also protected by SQL GRANT/REVOKE authorization, this vulnerability could also let an attacker view and corrupt sensitive data and run sensitive database functions and procedures. Mitigation: Users should upgrade to Java 21 and Derby 10.17.1.0. Alternatively, users who wish to remain on older Java versions should build their own Derby distribution from one of the release families to which the fix was backported: 10.16, 10.15, and 10.14. Those are the releases which correspond, respectively, with Java LTS versions 17, 11, and 8.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rcjc-c4pj-xxrp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-46337 Advisory: Apache Derby: LDAP injection vulnerability in authenticator IDs: CVE-2022-46337, GHSA-rcjc-c4pj-xxrp Record: https://patchnext.com/advisories/cve-2022-46337 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.derby:derby 10.16.1.2, 10.15.2.1, 10.14.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.derby:derby: affected >= 10.1.1.0, <= 10.1.3.1; >= 10.2.1.6, <= 10.2.2.0; >= 10.3.1.4, <= 10.3.3.0; >= 10.4.1.3, <= 10.4.2.0; >= 10.5.1.1, <= 10.5.3.0; >= 10.6.1.0, <= 10.6.2.1; >= 10.7.1.1, <= 10.7.1.1; >= 10.8.1.2, <= 10.8.3.0; >= 10.9.1.0, <= 10.9.1.0; >= 10.10.1.1, <= 10.10.2.0; >= 10.11.1.1, <= 10.11.1.1; >= 10.12.1.1, <= 10.12.1.1; >= 10.13.1.1, <= 10.13.1.1; >= 10.14.2.0, <= 10.14.2.0; >= 10.16.1.1, <= 10.16.1.1; >= 10.15.1.3, <= 10.15.2.0; fixed in 10.14.2.1, 10.15.2.1, 10.16.1.2 ## Suggested inspection (read-only) - Maven org.apache.derby:derby: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.derby:derby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rcjc-c4pj-xxrp (GitHub-reviewed advisory GHSA-rcjc-c4pj-xxrp lists affected ranges: Maven org.apache.derby:derby >=10.1.1.0 =10.2.1.6 =10.3.1.4 =10.4.1.3 =10.5.1.1 =10.6.1.0 =10.7.1.1 =10.8.1.2 =10.9.1.0 =10.10.1.1 =10.11.1.1 =10.12.1.1 =10.13.1.1 =10.14.2.0 =10.16.1.1 =10.15.1.3 <=10.15.2.0) Commands are suggestions: review each one before running it.
Loading voting…