Skip to content

← Actionable
High, CVSS 7.4

Path Traversal In MeterSpere leads to upload file to any path

CVE-2022-46178GHSA-9p62-x3c5-hr5p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.metersphere:metersphere 2.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2022-46178: 0.75% estimated exploitation activity in the next 30 days; percentile 55.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary MeterSphere allow users to upload file, but not check the file name, may lead to upload file to any path if the file name in upload request is falsified. Details Metersphere's FileUtils.java didn't check the filePath. Patches The vulnerability has been fixed in v2.5.1. https://github.com/metersphere/metersphere/commit/3a890eeeb8a6b0887927c876a73bdb3a99a82138 : add validation for file name. Workarounds It is recommended to upgrade the version to v2.5.1. For more information If you have any questions or comments about this advisory, please open an issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9p62-x3c5-hr5p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-46178

Advisory: Path Traversal In MeterSpere leads to upload file to any path
IDs: CVE-2022-46178, GHSA-9p62-x3c5-hr5p
Record: https://patchnext.com/advisories/cve-2022-46178 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.metersphere:metersphere 2.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.metersphere:metersphere: affected < 2.5.1; fixed in 2.5.1

## Suggested inspection (read-only)
- Maven io.metersphere:metersphere: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.metersphere:metersphere.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9p62-x3c5-hr5p (GitHub-reviewed advisory GHSA-9p62-x3c5-hr5p lists affected ranges: Maven io.metersphere:metersphere >=0 <2.5.1)

Commands are suggestions: review each one before running it.

Loading voting…