efs-utils and aws-efs-csi-driver have race condition during concurrent TLS mounts
CVE-2022-46174GHSA-4fv8-w65m-3932
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubernetes-sigs/aws-efs-csi-driver 1.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kubernetes-sigs/aws-efs-csi-driver
- Affected
- <= 1.4.7
- Fixed in
- 1.4.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4fv8-w65m-3932 lists affected ranges: Go github.com/kubernetes-sigs/aws-efs-csi-driver >=0 <=1.4.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2022-46174: 0.64% estimated exploitation activity in the next 30 days; percentile 50.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A potential race condition issue exists within the Amazon EFS mount helper in efs-utils versions v1.34.3 and below, and aws-efs-csi-driver versions v1.4.7 and below. When using TLS to mount file systems, the mount helper allocates a local port for stunnel to receive NFS connections prior to applying the TLS tunnel. In affected versions, concurrent mount operations can allocate the same local port, leading to either failed mount operations or an inappropriate mapping from an EFS customer’s local mount points to that customer’s EFS file systems. Affected versions: efs-utils <= v1.34.3, aws-efs-csi-driver <= v1.4.7 Patches The patches are included in efs-utils version v1.34.4 and newer, and in aws-efs-csi-driver v1.4.8 and newer. Workarounds There is no recommended work around. We recommend affected users update the installed version of efs-utils to v1.34.4+ or aws-efs-csi-driver to v1.4.8+ to address this issue. References…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4fv8-w65m-3932
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-46174 Advisory: efs-utils and aws-efs-csi-driver have race condition during concurrent TLS mounts IDs: CVE-2022-46174, GHSA-4fv8-w65m-3932 Record: https://patchnext.com/advisories/cve-2022-46174 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kubernetes-sigs/aws-efs-csi-driver 1.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kubernetes-sigs/aws-efs-csi-driver: affected <= 1.4.7; fixed in 1.4.8 ## Suggested inspection (read-only) - Go github.com/kubernetes-sigs/aws-efs-csi-driver: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kubernetes-sigs/aws-efs-csi-driver. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4fv8-w65m-3932 (GitHub-reviewed advisory GHSA-4fv8-w65m-3932 lists affected ranges: Go github.com/kubernetes-sigs/aws-efs-csi-driver >=0 <=1.4.7) Commands are suggestions: review each one before running it.
Loading voting…