Skip to content

← Actionable
Medium, CVSS 6.8

Tauri Filesystem Scope Glob Pattern is too Permissive

CVE-2022-46171GHSA-6mv3-wm7j-h4w5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tauri 2.0.0-alpha.2, 1.2.3, 1.1.3, 1.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io tauri

    Affected
    >= 1.0.0, < 1.0.8>= 1.1.0, < 1.1.3>= 1.2.0, < 1.2.3>= 2.0.0-alpha.0, < 2.0.0-alpha.2
    Fixed in
    1.2.3, 1.0.8, 2.0.0-alpha.2, 1.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2022-46171: 1.07% estimated exploitation activity in the next 30 days; percentile 64.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The filesystem glob pattern wildcards , ?, and [...] match file path literals and leading dots by default, which unintentionally exposes sub folder content of allowed paths. Example: The fs scope $HOME/.key would also allow $HOME/.ssh/secret.key to be read even though it is in a sub directory of $HOME and is inside a hidden folder. Scopes without the wildcards are not affected. As allows for sub directories the behavior there is also as expected. Patches The issue has been patched in the latest release and was backported into the currently supported 1.x branches. Workarounds No workaround is known at the time of publication. References The original report contained information that the dialog.open component automatically allows one sub directory to be read, regardless of the recursive option. Imagine a file system looking like Reproduction steps: 1. Trying to load “file.txt” or “deepfile.txt” doesn’t work. Expected 2. Select “documents” as folder to open(ie. with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6mv3-wm7j-h4w5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-46171

Advisory: Tauri Filesystem Scope Glob Pattern is too Permissive
IDs: CVE-2022-46171, GHSA-6mv3-wm7j-h4w5
Record: https://patchnext.com/advisories/cve-2022-46171 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tauri 2.0.0-alpha.2, 1.2.3, 1.1.3, 1.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io tauri: affected >= 1.0.0, < 1.0.8; >= 1.1.0, < 1.1.3; >= 1.2.0, < 1.2.3; >= 2.0.0-alpha.0, < 2.0.0-alpha.2; fixed in 1.2.3, 1.0.8, 2.0.0-alpha.2, 1.1.3

## Suggested inspection (read-only)
- crates.io tauri: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tauri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6mv3-wm7j-h4w5 (GitHub-reviewed advisory GHSA-6mv3-wm7j-h4w5 lists affected ranges: crates.io tauri >=1.0.0 =1.1.0 =1.2.0 =2.0.0-alpha.0 <2.0.0-alpha.2)

Commands are suggestions: review each one before running it.

Loading voting…