Spring Boot Admins integrated notifier support allows arbitrary code execution
CVE-2022-46166GHSA-w3x5-427h-wfq6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (de.codecentric:spring-boot-admin 3.0.0-M6, 2.7.8, 2.6.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven de.codecentric:spring-boot-admin
- Affected
- < 2.6.10>= 2.7.0, < 2.7.8>= 3.0.0-M1, < 3.0.0-M6
- Fixed in
- 3.0.0-M6, 2.6.10, 2.7.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3x5-427h-wfq6 lists affected ranges: Maven de.codecentric:spring-boot-admin >=0 =2.7.0 =3.0.0-M1 <3.0.0-M6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2022-46166: 1.57% estimated exploitation activity in the next 30 days; percentile 75.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact All users who run Spring Boot Admin Server, having enabled Notifiers (e.g. Teams-Notifier) and write access to environment variables via UI are possibly affected. Patches In the most recent releases of Spring Boot Admin 2.6.10 and 2.7.8 the issue is fixed by implementing SimpleExecutionContext of SpEL. This prevents the arbitrary code execution (i.e. SpEL injection). Workarounds Disable any notifier Disable write access (POST request) on /env actuator endpoint
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w3x5-427h-wfq6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-46166 Advisory: Spring Boot Admins integrated notifier support allows arbitrary code execution IDs: CVE-2022-46166, GHSA-w3x5-427h-wfq6 Record: https://patchnext.com/advisories/cve-2022-46166 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: de.codecentric:spring-boot-admin 3.0.0-M6, 2.7.8, 2.6.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven de.codecentric:spring-boot-admin: affected < 2.6.10; >= 2.7.0, < 2.7.8; >= 3.0.0-M1, < 3.0.0-M6; fixed in 3.0.0-M6, 2.6.10, 2.7.8 ## Suggested inspection (read-only) - Maven de.codecentric:spring-boot-admin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on de.codecentric:spring-boot-admin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w3x5-427h-wfq6 (GitHub-reviewed advisory GHSA-w3x5-427h-wfq6 lists affected ranges: Maven de.codecentric:spring-boot-admin >=0 =2.7.0 =3.0.0-M1 <3.0.0-M6) Commands are suggestions: review each one before running it.
Loading voting…