NodeBB vulnerable to account takeover via prototype vulnerability
CVE-2022-46164GHSA-rf3g-v8p5-p675
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodebb 2.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nodebb
- Affected
- < 2.6.1
- Fixed in
- 2.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rf3g-v8p5-p675 lists affected ranges: npm nodebb >=0 <2.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rf3g-v8p5-p675 lists affected ranges: npm nodebb >=0 <2.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2022-46164: 47.37% estimated exploitation activity in the next 30 days; percentile 98.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to a plain object with a prototype being used in socket.io message handling a specially crafted payload can be used to impersonate other users and takeover accounts. Patches Patched in 2.6.1 Workarounds Site maintainers can cherry-pick https://github.com/NodeBB/NodeBB/commit/48d143921753914da45926cca6370a92ed0c46b8 into their codebase to patch the exploit. For more information If you have any questions or comments about this advisory: Discuss it on our community forum Email us at support@nodebb.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rf3g-v8p5-p675
- Revision 1 · created ·
Published from osv record GHSA-rf3g-v8p5-p675
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-46164 Advisory: NodeBB vulnerable to account takeover via prototype vulnerability IDs: CVE-2022-46164, GHSA-rf3g-v8p5-p675 Record: https://patchnext.com/advisories/cve-2022-46164 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nodebb 2.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nodebb: affected < 2.6.1; fixed in 2.6.1 ## Suggested inspection (read-only) - `npm ls nodebb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nodebb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rf3g-v8p5-p675 (OSV record GHSA-rf3g-v8p5-p675 lists affected ranges: npm nodebb >=0 <2.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-rf3g-v8p5-p675 (GitHub-reviewed advisory GHSA-rf3g-v8p5-p675 lists affected ranges: npm nodebb >=0 <2.6.1) Commands are suggestions: review each one before running it.
Loading voting…