Skip to content

← Actionable
High, CVSS 8.4amended

XBlock vulnerable to Cross-Site Scripting (XSS)

CVE-2022-46147GHSA-qv6c-367r-3w6q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xblock-drag-and-drop-v2 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-46147: 0.90% estimated exploitation activity in the next 30 days; percentile 59.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact XSS Vulnerability in multiple XBlock Fields. Any platform that has deployed the XBlock will be impacted. Patches https://github.com/openedx/xblock-drag-and-drop-v2/commit/53c4482f9bb6d8c7ccdf5253bd82c84a222b2492 The fix is compatible with all Open edX releases newer than Lilac. Workarounds None. References https://github.com/openedx/xblock-drag-and-drop-v2/pull/295#issuecomment-1277693864

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qv6c-367r-3w6q

  2. Revision 1 · created ·

    Published from osv record GHSA-qv6c-367r-3w6q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-46147

Advisory: XBlock vulnerable to Cross-Site Scripting (XSS)
IDs: CVE-2022-46147, GHSA-qv6c-367r-3w6q
Record: https://patchnext.com/advisories/cve-2022-46147 (revision 2, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xblock-drag-and-drop-v2 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI xblock-drag-and-drop-v2: affected < 3.0.0; fixed in 3.0.0

## Suggested inspection (read-only)
- `python -m pip show xblock-drag-and-drop-v2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xblock-drag-and-drop-v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qv6c-367r-3w6q (OSV record GHSA-qv6c-367r-3w6q lists affected ranges: PyPI xblock-drag-and-drop-v2 >=0 <3.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qv6c-367r-3w6q (GitHub-reviewed advisory GHSA-qv6c-367r-3w6q lists affected ranges: PyPI xblock-drag-and-drop-v2 >=0 <3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…