AList vulnerable to Improper Preservation of Permissions
CVE-2022-45968GHSA-4gjr-vgfx-9qvw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/alist-org/alist/v3 3.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/alist-org/alist/v3
- Affected
- < 3.5.1
- Fixed in
- 3.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4gjr-vgfx-9qvw lists affected ranges: Go github.com/alist-org/alist/v3 >=0 <3.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-45968: 1.02% estimated exploitation activity in the next 30 days; percentile 63.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Alist v3.4.0 is vulnerable to File Upload. A user with only file upload permission can upload any file to any folder (even a password protected one). Version 3.5.1 contains a patch.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4gjr-vgfx-9qvw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-45968 Advisory: AList vulnerable to Improper Preservation of Permissions IDs: CVE-2022-45968, GHSA-4gjr-vgfx-9qvw Record: https://patchnext.com/advisories/cve-2022-45968 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/alist-org/alist/v3 3.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/alist-org/alist/v3: affected < 3.5.1; fixed in 3.5.1 ## Suggested inspection (read-only) - Go github.com/alist-org/alist/v3: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/alist-org/alist/v3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4gjr-vgfx-9qvw (GitHub-reviewed advisory GHSA-4gjr-vgfx-9qvw lists affected ranges: Go github.com/alist-org/alist/v3 >=0 <3.5.1) Commands are suggestions: review each one before running it.
Loading voting…