Apache AGE: Python and Golang drivers allow data manipulation and exposure due to SQL injection
CVE-2022-45786GHSA-6p5q-h963-pwwf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-age-python 0.0.5; github.com/apache/age/drivers/golang 1.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-age-python
- Affected
- <= 0.0.4
- Fixed in
- 0.0.5
Go github.com/apache/age/drivers/golang
- Affected
- <= 1.1.0
- Fixed in
- 1.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6p5q-h963-pwwf lists affected ranges: Go github.com/apache/age/drivers/golang >=0 =0 <0.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6p5q-h963-pwwf lists affected ranges: Go github.com/apache/age/drivers/golang >=0 =0 <=0.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-45786: 0.96% estimated exploitation activity in the next 30 days; percentile 61.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There are issues with the AGE drivers for Golang and Python that enable SQL injections to occur. This impacts AGE for PostgreSQL 11 & AGE for PostgreSQL 12, all versions up-to-and-including 1.1.0, when using those drivers. The fix is to update to the latest Golang and Python drivers in addition to the latest version of AGE that is used for PostgreSQL 11 or PostgreSQL 12. The update of AGE will add a new function to enable parameterization of the cypher() function, which, in conjunction with the driver updates, will resolve this issue. Background (for those who want more information): After thoroughly researching this issue, we found that due to the nature of the cypher() function, it was not easy to parameterize the values passed into it. This enabled SQL injections, if the developer of the driver wasn't careful. The developer of the Golang and Pyton drivers didn't fully utilize parameterization, likely because of this, thus enabling SQL injections. The obvious fix to this issue is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6p5q-h963-pwwf
- Revision 1 · created ·
Published from osv record GHSA-6p5q-h963-pwwf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-45786 Advisory: Apache AGE: Python and Golang drivers allow data manipulation and exposure due to SQL injection IDs: CVE-2022-45786, GHSA-6p5q-h963-pwwf Record: https://patchnext.com/advisories/cve-2022-45786 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-age-python 0.0.5; github.com/apache/age/drivers/golang 1.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-age-python: affected <= 0.0.4; fixed in 0.0.5 - Go github.com/apache/age/drivers/golang: affected <= 1.1.0; fixed in 1.1.1 ## Suggested inspection (read-only) - `python -m pip show apache-age-python`: prints the installed version. Run with the environment that serves production active. - Go github.com/apache/age/drivers/golang: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-age-python, github.com/apache/age/drivers/golang. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6p5q-h963-pwwf (OSV record GHSA-6p5q-h963-pwwf lists affected ranges: Go github.com/apache/age/drivers/golang >=0 =0 <0.0.5 (fixed)) - Verified: https://github.com/advisories/GHSA-6p5q-h963-pwwf (GitHub-reviewed advisory GHSA-6p5q-h963-pwwf lists affected ranges: Go github.com/apache/age/drivers/golang >=0 =0 <=0.0.4) Commands are suggestions: review each one before running it.
Loading voting…