Joplin Desktop App vulnerable to Cross-site Scripting
CVE-2022-45598GHSA-h6c2-879r-jffh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (joplin 2.9.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm joplin
- Affected
- < 2.9.17
- Fixed in
- 2.9.17
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h6c2-879r-jffh lists affected ranges: npm joplin >=0 <2.9.17 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h6c2-879r-jffh lists affected ranges: npm joplin >=0 <2.9.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-45598: 0.45% estimated exploitation activity in the next 30 days; percentile 39.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross Site Scripting vulnerability in Joplin Desktop App before v2.9.17 allows attacker to execute arbitrary code via improper santization.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h6c2-879r-jffh
- Revision 1 · created ·
Published from osv record GHSA-h6c2-879r-jffh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-45598 Advisory: Joplin Desktop App vulnerable to Cross-site Scripting IDs: CVE-2022-45598, GHSA-h6c2-879r-jffh Record: https://patchnext.com/advisories/cve-2022-45598 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: joplin 2.9.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm joplin: affected < 2.9.17; fixed in 2.9.17 ## Suggested inspection (read-only) - `npm ls joplin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on joplin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h6c2-879r-jffh (OSV record GHSA-h6c2-879r-jffh lists affected ranges: npm joplin >=0 <2.9.17 (fixed)) - Verified: https://github.com/advisories/GHSA-h6c2-879r-jffh (GitHub-reviewed advisory GHSA-h6c2-879r-jffh lists affected ranges: npm joplin >=0 <2.9.17) Commands are suggestions: review each one before running it.
Loading voting…