Apache Airflow Contains Open Redirect
CVE-2022-45402GHSA-rg94-84xj-7gq3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- < 2.4.3
- Fixed in
- 2.4.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rg94-84xj-7gq3 lists affected ranges: PyPI apache-airflow >=0 <2.4.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rg94-84xj-7gq3 lists affected ranges: PyPI apache-airflow >=0 <2.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-45402: 81.84% estimated exploitation activity in the next 30 days; percentile 99.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Airflow versions prior to 2.4.3, there was an open redirect in the webserver's /login endpoint.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rg94-84xj-7gq3
- Revision 1 · created ·
Published from osv record GHSA-rg94-84xj-7gq3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-45402 Advisory: Apache Airflow Contains Open Redirect IDs: CVE-2022-45402, GHSA-rg94-84xj-7gq3 Record: https://patchnext.com/advisories/cve-2022-45402 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected < 2.4.3; fixed in 2.4.3 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rg94-84xj-7gq3 (OSV record GHSA-rg94-84xj-7gq3 lists affected ranges: PyPI apache-airflow >=0 <2.4.3 (fixed)) - Verified: https://github.com/advisories/GHSA-rg94-84xj-7gq3 (GitHub-reviewed advisory GHSA-rg94-84xj-7gq3 lists affected ranges: PyPI apache-airflow >=0 <2.4.3) Commands are suggestions: review each one before running it.
Loading voting…