django-photologue vulnerable to Cross-site Scripting
CVE-2022-4526GHSA-287q-jfcp-9vhv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (django-photologue 3.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI django-photologue
- Affected
- <= 3.15.1
- Fixed in
- 3.16
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-287q-jfcp-9vhv lists affected ranges: PyPI django-photologue >=0 <3.16 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-287q-jfcp-9vhv lists affected ranges: PyPI django-photologue >=0 <=3.15.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2022-4526: 0.56% estimated exploitation activity in the next 30 days; percentile 46.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in django-photologue up to 3.15.1 and classified as problematic. Affected by this issue is some unknown functionality of the file photologue/templates/photologue/photodetail.html of the component Default Template Handler. The manipulation of the argument object.caption leads to cross site scripting. The attack may be launched remotely. Upgrading to version 3.16 is able to address this issue. The name of the patch is 960cb060ce5e2964e6d716ff787c72fc18a371e7. It is recommended to apply a patch to fix this issue. VDB-215906 is the identifier assigned to this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-287q-jfcp-9vhv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-287q-jfcp-9vhv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-4526 Advisory: django-photologue vulnerable to Cross-site Scripting IDs: CVE-2022-4526, GHSA-287q-jfcp-9vhv Record: https://patchnext.com/advisories/cve-2022-4526 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: django-photologue 3.16. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI django-photologue: affected <= 3.15.1; fixed in 3.16 ## Suggested inspection (read-only) - `python -m pip show django-photologue`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on django-photologue. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-287q-jfcp-9vhv (OSV record GHSA-287q-jfcp-9vhv lists affected ranges: PyPI django-photologue >=0 <3.16 (fixed)) - Verified: https://github.com/advisories/GHSA-287q-jfcp-9vhv (GitHub-reviewed advisory GHSA-287q-jfcp-9vhv lists affected ranges: PyPI django-photologue >=0 <=3.15.1) Commands are suggestions: review each one before running it.
Loading voting…