Skip to content

← Actionable
Critical, CVSS 9.1

Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library

CVE-2022-45152GHSA-xqcf-vgqc-pcmg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.0.5, 3.11.11, 3.9.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 3.9, < 3.9.18>= 3.11, < 3.11.11>= 4.0, < 4.0.5
    Fixed in
    3.11.11, 3.9.18, 4.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2022-45152: 1.47% estimated exploitation activity in the next 30 days; percentile 73.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A blind Server-Side Request Forgery (SSRF) vulnerability was found in Moodle. This flaw exists due to insufficient validation of user-supplied input in LTI provider library. The library does not utilise Moodle's inbuilt cURL helper, which resulted in a blind SSRF risk. An attacker can send a specially crafted HTTP request and trick the application to initiate requests to arbitrary systems. This vulnerability allows a remote attacker to perform SSRF attacks.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xqcf-vgqc-pcmg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-45152

Advisory: Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library
IDs: CVE-2022-45152, GHSA-xqcf-vgqc-pcmg
Record: https://patchnext.com/advisories/cve-2022-45152 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.0.5, 3.11.11, 3.9.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 3.9, < 3.9.18; >= 3.11, < 3.11.11; >= 4.0, < 4.0.5; fixed in 3.11.11, 3.9.18, 4.0.5

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xqcf-vgqc-pcmg (GitHub-reviewed advisory GHSA-xqcf-vgqc-pcmg lists affected ranges: Packagist moodle/moodle >=3.9 =3.11 =4.0 <4.0.5)

Commands are suggestions: review each one before running it.

Loading voting…