Moodle reflected cross-site scripting vulnerability in policy tool
CVE-2022-45150GHSA-6gx2-g773-hv9h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.0.5, 3.11.11, 3.9.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 3.9, < 3.9.18>= 3.11, < 3.11.11>= 4.0, < 4.0.5
- Fixed in
- 3.11.11, 3.9.18, 4.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6gx2-g773-hv9h lists affected ranges: Packagist moodle/moodle >=3.9 =3.11 =4.0 <4.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-45150: 0.74% estimated exploitation activity in the next 30 days; percentile 54.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A reflected cross-site scripting vulnerability was discovered in Moodle. This flaw exists due to insufficient sanitization of user-supplied data in policy tool. An attacker can trick the victim to open a specially crafted link that executes an arbitrary HTML and script code in user's browser in context of vulnerable website. This vulnerability may allow an attacker to perform cross-site scripting (XSS) attacks to gain access potentially sensitive information and modification of web pages.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6gx2-g773-hv9h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-45150 Advisory: Moodle reflected cross-site scripting vulnerability in policy tool IDs: CVE-2022-45150, GHSA-6gx2-g773-hv9h Record: https://patchnext.com/advisories/cve-2022-45150 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.0.5, 3.11.11, 3.9.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 3.9, < 3.9.18; >= 3.11, < 3.11.11; >= 4.0, < 4.0.5; fixed in 3.11.11, 3.9.18, 4.0.5 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6gx2-g773-hv9h (GitHub-reviewed advisory GHSA-6gx2-g773-hv9h lists affected ranges: Packagist moodle/moodle >=3.9 =3.11 =4.0 <4.0.5) Commands are suggestions: review each one before running it.
Loading voting…