Skip to content

← Actionable
Medium, CVSS 5.4

Cross-Site Request Forgery in Moodle

CVE-2022-45149GHSA-8v23-w4w5-w83c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.0.5, 3.11.11, 3.9.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 3.9.0, < 3.9.18>= 3.11.0, < 3.11.11>= 4.0.0, < 4.0.5
    Fixed in
    3.11.11, 3.9.18, 4.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2022-45149: 0.44% estimated exploitation activity in the next 30 days; percentile 38.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in Moodle which exists due to insufficient validation of the HTTP request origin in course redirect URL. A user's CSRF token was unnecessarily included in the URL when being redirected to a course they have just restored. A remote attacker can trick the victim to visit a specially crafted web page and perform arbitrary actions on behalf of the victim on the vulnerable website. This flaw allows an attacker to perform cross-site request forgery attacks.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8v23-w4w5-w83c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-45149

Advisory: Cross-Site Request Forgery in Moodle
IDs: CVE-2022-45149, GHSA-8v23-w4w5-w83c
Record: https://patchnext.com/advisories/cve-2022-45149 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.0.5, 3.11.11, 3.9.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 3.9.0, < 3.9.18; >= 3.11.0, < 3.11.11; >= 4.0.0, < 4.0.5; fixed in 3.11.11, 3.9.18, 4.0.5

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8v23-w4w5-w83c (GitHub-reviewed advisory GHSA-8v23-w4w5-w83c lists affected ranges: Packagist moodle/moodle >=3.9.0 =3.11.0 =4.0.0 <4.0.5)

Commands are suggestions: review each one before running it.

Loading voting…