Apache Sling Engine vulnerable to cross-site scripting (XSS) that can lead to privilege escalation
CVE-2022-45064GHSA-mg46-f9h5-g27x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.sling:org.apache.sling.engine 2.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.sling:org.apache.sling.engine
- Affected
- < 2.14.0
- Fixed in
- 2.14.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mg46-f9h5-g27x lists affected ranges: Maven org.apache.sling:org.apache.sling.engine >=0 <2.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2022-45064: 1.12% estimated exploitation activity in the next 30 days; percentile 66.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power. Please update to Apache Sling Engine version 2.14.0 or newer and enable the "Check Content-Type overrides" configuration option.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mg46-f9h5-g27x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-45064 Advisory: Apache Sling Engine vulnerable to cross-site scripting (XSS) that can lead to privilege escalation IDs: CVE-2022-45064, GHSA-mg46-f9h5-g27x Record: https://patchnext.com/advisories/cve-2022-45064 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.sling:org.apache.sling.engine 2.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.sling:org.apache.sling.engine: affected < 2.14.0; fixed in 2.14.0 ## Suggested inspection (read-only) - Maven org.apache.sling:org.apache.sling.engine: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.sling:org.apache.sling.engine. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mg46-f9h5-g27x (GitHub-reviewed advisory GHSA-mg46-f9h5-g27x lists affected ranges: Maven org.apache.sling:org.apache.sling.engine >=0 <2.14.0) Commands are suggestions: review each one before running it.
Loading voting…