Skip to content

← Actionable
Critical, CVSS 9.8

Undertow client not checking server identity presented by server certificate in https connections

CVE-2022-4492GHSA-pfcc-3g6r-8rg8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.undertow:undertow-core 2.3.5.Final, 2.2.24.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-4492: 0.60% estimated exploitation activity in the next 30 days; percentile 48.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The undertow client is not checking the server identity presented by the server certificate in https connections. This should be performed by default in https and in http/2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pfcc-3g6r-8rg8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-4492

Advisory: Undertow client not checking server identity presented by server certificate in https connections
IDs: CVE-2022-4492, GHSA-pfcc-3g6r-8rg8
Record: https://patchnext.com/advisories/cve-2022-4492 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.undertow:undertow-core 2.3.5.Final, 2.2.24.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.undertow:undertow-core: affected >= 2.3.0, < 2.3.5.Final; < 2.2.24.Final; fixed in 2.2.24.Final, 2.3.5.Final

## Suggested inspection (read-only)
- Maven io.undertow:undertow-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.undertow:undertow-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pfcc-3g6r-8rg8 (GitHub-reviewed advisory GHSA-pfcc-3g6r-8rg8 lists affected ranges: Maven io.undertow:undertow-core >=2.3.0 =0 <2.2.24.Final)

Commands are suggestions: review each one before running it.

Loading voting…