Apache Kylin vulnerable to Command injection by Diagnosis Controller
CVE-2022-44621GHSA-w9rv-xmf7-x3gh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.kylin:kylin-server-base 4.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.kylin:kylin-server-base
- Affected
- >= 2.0.0, < 4.0.3
- Fixed in
- 4.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w9rv-xmf7-x3gh lists affected ranges: Maven org.apache.kylin:kylin-server-base >=2.0.0 <4.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-44621: 3.05% estimated exploitation activity in the next 30 days; percentile 87.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Diagnosis Controller miss parameter validation, so user may attacked by command injection via HTTP Request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w9rv-xmf7-x3gh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-44621 Advisory: Apache Kylin vulnerable to Command injection by Diagnosis Controller IDs: CVE-2022-44621, GHSA-w9rv-xmf7-x3gh Record: https://patchnext.com/advisories/cve-2022-44621 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.kylin:kylin-server-base 4.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.kylin:kylin-server-base: affected >= 2.0.0, < 4.0.3; fixed in 4.0.3 ## Suggested inspection (read-only) - Maven org.apache.kylin:kylin-server-base: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.kylin:kylin-server-base. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w9rv-xmf7-x3gh (GitHub-reviewed advisory GHSA-w9rv-xmf7-x3gh lists affected ranges: Maven org.apache.kylin:kylin-server-base >=2.0.0 <4.0.3) Commands are suggestions: review each one before running it.
Loading voting…