Skip to content

← Actionable
Unrated

Denial of service via multipart parsing in Rack

CVE-2022-44572GHSA-rqv2-275x-2jq5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.0.4.1, 2.2.6.1, 2.1.4.2, 2.0.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rack

    Affected
    >= 2.0.0, < 2.0.9.2>= 2.1.0.0, < 2.1.4.2>= 2.2.0.0, < 2.2.6.1>= 3.0.0.0, < 3.0.4.1
    Fixed in
    3.0.4.1, 2.2.6.1, 2.0.9.2, 2.1.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2022-44572: 1.62% estimated exploitation activity in the next 30 days; percentile 76.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a denial of service vulnerability in the multipart parsing component of Rack. This vulnerability has been assigned the CVE identifier CVE-2022-44572. Versions Affected: = 2.0.0 Not affected: None. Fixed Versions: 2.0.9.2, 2.1.4.2, 2.2.6.1, 3.0.0.1 Impact Carefully crafted input can cause RFC2183 multipart boundary parsing in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that parse multipart posts using Rack (virtually all Rails applications) are impacted. Releases The fixed releases are available at the normal locations. Workarounds There are no feasible workarounds for this issue. Patches To aid users who aren’t able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset. 2-0-Forbid-control-characters-in-attributes.patch - Patch for 2.0 series 2-1-Forbid-control-characters-in-attributes.patch - Patch for 2.1 series…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rqv2-275x-2jq5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-44572

Advisory: Denial of service via multipart parsing in Rack
IDs: CVE-2022-44572, GHSA-rqv2-275x-2jq5
Record: https://patchnext.com/advisories/cve-2022-44572 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack 3.0.4.1, 2.2.6.1, 2.1.4.2, 2.0.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack: affected >= 2.0.0, < 2.0.9.2; >= 2.1.0.0, < 2.1.4.2; >= 2.2.0.0, < 2.2.6.1; >= 3.0.0.0, < 3.0.4.1; fixed in 3.0.4.1, 2.2.6.1, 2.0.9.2, 2.1.4.2

## Suggested inspection (read-only)
- RubyGems rack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rqv2-275x-2jq5 (GitHub-reviewed advisory GHSA-rqv2-275x-2jq5 lists affected ranges: RubyGems rack >=2.0.0 =2.1.0.0 =2.2.0.0 =3.0.0.0 <3.0.4.1)

Commands are suggestions: review each one before running it.

Loading voting…