Denial of Service Vulnerability in ActiveRecord's PostgreSQL adapter
CVE-2022-44566GHSA-579w-22j4-4749
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (activerecord 7.0.4.1, 6.1.7.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems activerecord
- Affected
- >= 7.0.0, < 7.0.4.1< 6.1.7.1
- Fixed in
- 6.1.7.1, 7.0.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-579w-22j4-4749 lists affected ranges: RubyGems activerecord >=7.0.0 =0 <6.1.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-44566: 1.26% estimated exploitation activity in the next 30 days; percentile 69.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a potential denial of service vulnerability present in ActiveRecord's PostgreSQL adapter. This has been assigned the CVE identifier CVE-2022-44566. Versions Affected: All. Not affected: None. Fixed Versions - 2.3.18.47 (Rails LTS, which is a paid service and not part of the rubygem) - 3.2.22.34 (Rails LTS, which is a paid service and not part of the rubygem) - 4.2.11.27 (Rails LTS, which is a paid service and not part of the rubygem) - 5.2.8.15 (Rails LTS, which is a paid service and not part of the rubygem) - 6.1.7.1 - 7.0.4.1 Impact In ActiveRecord < 7.0.4.1 and < 6.1.7.1, when a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service. Releases The fixed releases are available at the normal locations. Workarounds Ensure that user supplied input which is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-579w-22j4-4749
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-44566 Advisory: Denial of Service Vulnerability in ActiveRecord's PostgreSQL adapter IDs: CVE-2022-44566, GHSA-579w-22j4-4749 Record: https://patchnext.com/advisories/cve-2022-44566 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: activerecord 7.0.4.1, 6.1.7.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems activerecord: affected >= 7.0.0, < 7.0.4.1; < 6.1.7.1; fixed in 6.1.7.1, 7.0.4.1 ## Suggested inspection (read-only) - RubyGems activerecord: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on activerecord. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-579w-22j4-4749 (GitHub-reviewed advisory GHSA-579w-22j4-4749 lists affected ranges: RubyGems activerecord >=7.0.0 =0 <6.1.7.1) Commands are suggestions: review each one before running it.
Loading voting…