openssl-src contains Double free after calling PEM_read_bio_ex
CVE-2022-4450GHSA-v5w6-wcm8-jm4q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-src 300.0.12, 111.25.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io openssl-src
- Affected
- < 111.25.0>= 300.0.0, < 300.0.12
- Fixed in
- 111.25.0, 300.0.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v5w6-wcm8-jm4q lists affected ranges: crates.io openssl-src >=0 =300.0.0 <300.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-4450: 28.59% estimated exploitation activity in the next 30 days; percentile 98.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The function PEMreadbioex() reads a PEM file from a BIO and parses and decodes the "name" (e.g. "CERTIFICATE"), any header data and the payload data. If the function succeeds then the "nameout", "header" and "data" arguments are populated with pointers to buffers containing the relevant decoded data. The caller is responsible for freeing those buffers. It is possible to construct a PEM file that results in 0 bytes of payload data. In this case PEMreadbioex() will return a failure code but will populate the header argument with a pointer to a buffer that has already been freed. If the caller also frees this buffer then a double free will occur. This will most likely lead to a crash. This could be exploited by an attacker who has the ability to supply malicious PEM files for parsing to achieve a denial of service attack. The functions PEMreadbio() and PEMread() are simple wrappers around PEMreadbioex() and therefore these functions are also directly affected. These functions are also…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v5w6-wcm8-jm4q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-4450 Advisory: openssl-src contains Double free after calling `PEM_read_bio_ex` IDs: CVE-2022-4450, GHSA-v5w6-wcm8-jm4q Record: https://patchnext.com/advisories/cve-2022-4450 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openssl-src 300.0.12, 111.25.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io openssl-src: affected < 111.25.0; >= 300.0.0, < 300.0.12; fixed in 111.25.0, 300.0.12 ## Suggested inspection (read-only) - crates.io openssl-src: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openssl-src. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v5w6-wcm8-jm4q (GitHub-reviewed advisory GHSA-v5w6-wcm8-jm4q lists affected ranges: crates.io openssl-src >=0 =300.0.0 <300.0.12) Commands are suggestions: review each one before running it.
Loading voting…