Resque Scheduler Reflected XSS In Delayed Jobs View
CVE-2022-44303GHSA-9hmq-fm33-x4xx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (resque-scheduler 4.10.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems resque-scheduler
- Affected
- >= 1.27.4, < 4.10.2
- Fixed in
- 4.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9hmq-fm33-x4xx lists affected ranges: RubyGems resque-scheduler >=1.27.4 <4.10.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N
- EPSS
- CVE-2022-44303: 0.65% estimated exploitation activity in the next 30 days; percentile 51.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Resque Scheduler version 1.27.4 and above are affected by a cross-site scripting vulnerability. A remote attacker can inject javascript code to the "{schedulejob}" or "args" parameter in /resque/delayed/jobs/{schedulejob}?args={argsid} to execute javascript at client side. Patches Fixed in v4.10.2 Workarounds No known workarounds at this time. It is recommended to not click on 3rd party or untrusted links to the resque-web interface until you have patched your application. References https://nvd.nist.gov/vuln/detail/CVE-2022-44303 https://github.com/resque/resque-scheduler/issues/761 https://github.com/resque/resque/issues/1885 https://github.com/resque/resque-scheduler/pull/780 https://github.com/resque/resque-scheduler/pull/783
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9hmq-fm33-x4xx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-44303 Advisory: Resque Scheduler Reflected XSS In Delayed Jobs View IDs: CVE-2022-44303, GHSA-9hmq-fm33-x4xx Record: https://patchnext.com/advisories/cve-2022-44303 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: resque-scheduler 4.10.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems resque-scheduler: affected >= 1.27.4, < 4.10.2; fixed in 4.10.2 ## Suggested inspection (read-only) - RubyGems resque-scheduler: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on resque-scheduler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9hmq-fm33-x4xx (GitHub-reviewed advisory GHSA-9hmq-fm33-x4xx lists affected ranges: RubyGems resque-scheduler >=1.27.4 <4.10.2) Commands are suggestions: review each one before running it.
Loading voting…