Plaintext storage of sensitive data in Rancher API and cluster.management.cattle.io objects
CVE-2022-43757GHSA-cq4p-vp5q-4522
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.7.1, 2.6.10, 2.5.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.5.0, < 2.5.17>= 2.6.0, < 2.6.10>= 2.7.0, < 2.7.1
- Fixed in
- 2.7.1, 2.5.17, 2.6.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cq4p-vp5q-4522 lists affected ranges: Go github.com/rancher/rancher >=2.5.0 =2.6.0 =2.7.0 <2.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-43757: 0.55% estimated exploitation activity in the next 30 days; percentile 46.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This issue affects Rancher versions from 2.5.0 up to and including 2.5.16, from 2.6.0 up to and including 2.6.9 and 2.7.0. It was discovered that the security advisory CVE-2021-36782 (GHSA-g7j7-h4q8-8w2f), previously released by Rancher, missed addressing some sensitive fields, secret tokens, encryption keys, and SSH keys that were still being stored in plaintext directly on Kubernetes objects like Clusters. The exposed credentials are visible in Rancher to authenticated Cluster Owners, Cluster Members, Project Owners and Project Members of that cluster on the endpoints: - /v1/management.cattle.io.cluster - /v1/management.cattle.io.clustertemplaterevisions The remaining sensitive fields are now stripped from Clusters and other objects and moved to a Secret before the object is stored. The Secret is retrieved when the credential is needed. For objects that existed before this security fix, a one-time migration happens on startup. The fields that have been addressed by this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cq4p-vp5q-4522
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-43757 Advisory: Plaintext storage of sensitive data in Rancher API and cluster.management.cattle.io objects IDs: CVE-2022-43757, GHSA-cq4p-vp5q-4522 Record: https://patchnext.com/advisories/cve-2022-43757 (revision 1, source checked 26 Oct 2026, 14:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.7.1, 2.6.10, 2.5.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rancher: affected >= 2.5.0, < 2.5.17; >= 2.6.0, < 2.6.10; >= 2.7.0, < 2.7.1; fixed in 2.7.1, 2.5.17, 2.6.10 ## Suggested inspection (read-only) - Go github.com/rancher/rancher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rancher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cq4p-vp5q-4522 (GitHub-reviewed advisory GHSA-cq4p-vp5q-4522 lists affected ranges: Go github.com/rancher/rancher >=2.5.0 =2.6.0 =2.7.0 <2.7.1) Commands are suggestions: review each one before running it.
Loading voting…