Skip to content

← Actionable
Medium, CVSS 5.9

Denial of service (DoS) when processing Git credentials

CVE-2022-43756GHSA-8fcj-gf77-47mg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/wrangler 1.0.1, 0.8.11, 0.8.5-security1, 0.7.4-security1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/rancher/wrangler

    Affected
    <= 0.7.3>= 0.8.0, <= 0.8.4>= 1.0.0, <= 1.0.0>= 0.8.6, < 0.8.11
    Fixed in
    0.7.4-security1, 0.8.5-security1, 1.0.1, 0.8.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2022-43756: 0.68% estimated exploitation activity in the next 30 days; percentile 52.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A denial of services (DoS) vulnerability was discovered in Wrangler Git package affecting versions up to and including v1.0.0. Specially crafted Git credentials can result in a denial of service (DoS) attack on an application that uses Wrangler due to the exhaustion of the available memory and CPU resources. This is caused by a lack of input validation of Git credentials before they are used, which may lead to a denial of service in some cases. This issue can be triggered when accessing both private and public Git repositories. Workarounds A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version. Patches Patched versions include v1.0.1 and later and the backported tags - v0.7.4-security1, v0.8.5-security1 and v0.8.11. For more information If you have any questions or comments about this advisory: Reach out to SUSE Rancher Security team for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8fcj-gf77-47mg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-43756

Advisory: Denial of service (DoS) when processing Git credentials
IDs: CVE-2022-43756, GHSA-8fcj-gf77-47mg
Record: https://patchnext.com/advisories/cve-2022-43756 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/wrangler 1.0.1, 0.8.11, 0.8.5-security1, 0.7.4-security1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rancher/wrangler: affected <= 0.7.3; >= 0.8.0, <= 0.8.4; >= 1.0.0, <= 1.0.0; >= 0.8.6, < 0.8.11; fixed in 0.7.4-security1, 0.8.5-security1, 1.0.1, 0.8.11

## Suggested inspection (read-only)
- Go github.com/rancher/wrangler: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rancher/wrangler.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8fcj-gf77-47mg (GitHub-reviewed advisory GHSA-8fcj-gf77-47mg lists affected ranges: Go github.com/rancher/wrangler >=0 =0.8.0 =1.0.0 =0.8.6 <0.8.11)

Commands are suggestions: review each one before running it.

Loading voting…