Apache Sling App CMS vulnerable to Cross-site Scripting
CVE-2022-43670GHSA-jj93-4jr5-x45h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.sling:org.apache.sling.cms 1.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.sling:org.apache.sling.cms
- Affected
- < 1.1.2
- Fixed in
- 1.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jj93-4jr5-x45h lists affected ranges: Maven org.apache.sling:org.apache.sling.cms >=0 <1.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-43670: 1.70% estimated exploitation activity in the next 30 days; percentile 77.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Cross-site Scripting vulnerability in Sling App CMS version 1.1.0 and prior may allow an authenticated remote attacker to perform a reflected cross site scripting (XSS) attack in the taxonomy management feature.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jj93-4jr5-x45h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-43670 Advisory: Apache Sling App CMS vulnerable to Cross-site Scripting IDs: CVE-2022-43670, GHSA-jj93-4jr5-x45h Record: https://patchnext.com/advisories/cve-2022-43670 (revision 1, source checked 26 Oct 2026, 16:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.sling:org.apache.sling.cms 1.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.sling:org.apache.sling.cms: affected < 1.1.2; fixed in 1.1.2 ## Suggested inspection (read-only) - Maven org.apache.sling:org.apache.sling.cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.sling:org.apache.sling.cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jj93-4jr5-x45h (GitHub-reviewed advisory GHSA-jj93-4jr5-x45h lists affected ranges: Maven org.apache.sling:org.apache.sling.cms >=0 <1.1.2) Commands are suggestions: review each one before running it.
Loading voting…