sqlite vulnerable to code execution due to Object coercion
CVE-2022-43441GHSA-jqv5-7xpx-qj74
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sqlite3 5.1.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sqlite3
- Affected
- >= 5.0.0, < 5.1.5
- Fixed in
- 5.1.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jqv5-7xpx-qj74 lists affected ranges: npm sqlite3 >=5.0.0 <5.1.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jqv5-7xpx-qj74 lists affected ranges: npm sqlite3 >=5.0.0 <5.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-43441: 2.36% estimated exploitation activity in the next 30 days; percentile 83.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to the underlying implementation of .ToString(), it's possible to execute arbitrary JavaScript, or to achieve a denial-of-service, if a binding parameter is a crafted Object. Users of sqlite3 v5.0.0 - v5.1.4 are affected by this. Patches Fixed in v5.1.5. All users are recommended to upgrade to v5.1.5 or later. Workarounds Ensure there is sufficient sanitization in the parent application to protect against invalid values being supplied to binding parameters. References Commit: https://github.com/TryGhost/node-sqlite3/commit/edb1934dd222ae55632e120d8f64552d5191c781 For more information If you have any questions or comments about this advisory: Email us at security@ghost.org Credits: Dave McDaniel of Cisco Talos
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jqv5-7xpx-qj74
- Revision 1 · created ·
Published from osv record GHSA-jqv5-7xpx-qj74
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-43441 Advisory: sqlite vulnerable to code execution due to Object coercion IDs: CVE-2022-43441, GHSA-jqv5-7xpx-qj74 Record: https://patchnext.com/advisories/cve-2022-43441 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sqlite3 5.1.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sqlite3: affected >= 5.0.0, < 5.1.5; fixed in 5.1.5 ## Suggested inspection (read-only) - `npm ls sqlite3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sqlite3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jqv5-7xpx-qj74 (OSV record GHSA-jqv5-7xpx-qj74 lists affected ranges: npm sqlite3 >=5.0.0 <5.1.5 (fixed)) - Verified: https://github.com/advisories/GHSA-jqv5-7xpx-qj74 (GitHub-reviewed advisory GHSA-jqv5-7xpx-qj74 lists affected ranges: npm sqlite3 >=5.0.0 <5.1.5) Commands are suggestions: review each one before running it.
Loading voting…