Apache Kylin vulnerable to Command injection by Useless configuration
CVE-2022-43396GHSA-f5q9-j9r2-34gq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.kylin:kylin 4.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.kylin:kylin
- Affected
- >= 2.0.0, < 4.0.3
- Fixed in
- 4.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f5q9-j9r2-34gq lists affected ranges: Maven org.apache.kylin:kylin >=2.0.0 <4.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-43396: 55.28% estimated exploitation activity in the next 30 days; percentile 99.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In the fix for CVE-2022-24697, a blacklist is used to filter user input commands. But there is a risk of being bypassed. The user can control the command by controlling the kylin.engine.spark-cmd parameter of conf.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f5q9-j9r2-34gq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-43396 Advisory: Apache Kylin vulnerable to Command injection by Useless configuration IDs: CVE-2022-43396, GHSA-f5q9-j9r2-34gq Record: https://patchnext.com/advisories/cve-2022-43396 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.kylin:kylin 4.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.kylin:kylin: affected >= 2.0.0, < 4.0.3; fixed in 4.0.3 ## Suggested inspection (read-only) - Maven org.apache.kylin:kylin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.kylin:kylin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f5q9-j9r2-34gq (GitHub-reviewed advisory GHSA-f5q9-j9r2-34gq lists affected ranges: Maven org.apache.kylin:kylin >=2.0.0 <4.0.3) Commands are suggestions: review each one before running it.
Loading voting…