Skip to content

← Actionable
Medium, CVSS 6.1

CRI-O vulnerable to /etc/passwd tampering resulting in Privilege Escalation

CVE-2022-4318GHSA-cm9x-c3rh-7rc4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cri-o/cri-o 1.26.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:L/I:H/A:N
EPSS
  • CVE-2022-4318: 0.29% estimated exploitation activity in the next 30 days; percentile 21.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It is possible to craft an environment variable with newlines to add entries to a container's /etc/passwd. It is possible to circumvent admission validation of username/UID by adding such an entry. Note: because the pod author is in control of the container's /etc/passwd, this is not considered a new risk factor. However, this advisory is being opened for transparency and as a way of tracking fixes. Patches 1.26.0 will have the fix. More patches will be posted as they're available. Workarounds Additional security controls like SELinux should prevent any damage a container is able to do with root on the host. Using SELinux is recommended because this class of attack is already possible by manually editing the container's /etc/passwd References

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cm9x-c3rh-7rc4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-4318

Advisory: CRI-O vulnerable to /etc/passwd tampering resulting in Privilege Escalation
IDs: CVE-2022-4318, GHSA-cm9x-c3rh-7rc4
Record: https://patchnext.com/advisories/cve-2022-4318 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cri-o/cri-o 1.26.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cri-o/cri-o: affected < 1.26.0; fixed in 1.26.0

## Suggested inspection (read-only)
- Go github.com/cri-o/cri-o: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cri-o/cri-o.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cm9x-c3rh-7rc4 (GitHub-reviewed advisory GHSA-cm9x-c3rh-7rc4 lists affected ranges: Go github.com/cri-o/cri-o >=0 <1.26.0)

Commands are suggestions: review each one before running it.

Loading voting…