Skip to content

← Actionable
Medium, CVSS 5.4

SilverStripe Subsite weakens file permissions

CVE-2022-42949GHSA-cx45-565q-6qx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/subsites 2.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2022-42949: 0.56% estimated exploitation activity in the next 30 days; percentile 46.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The subsites module can weaken edit restrictions on some files and allow a malicious user to edit files they do not have edit rights to. This only affects projects with the subsites module installed. Regression testing should focus on custom file logic. Be advised that this is not a case of a user being able to edit a file in subsites they do not have access to. As a reminder, all separation of content achieved with the subsites module should be viewed as cosmetic and not appropriate for security-critical applications.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cx45-565q-6qx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-42949

Advisory: SilverStripe Subsite weakens file permissions
IDs: CVE-2022-42949, GHSA-cx45-565q-6qx8
Record: https://patchnext.com/advisories/cve-2022-42949 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/subsites 2.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/subsites: affected >= 2.0.0, < 2.6.1; fixed in 2.6.1

## Suggested inspection (read-only)
- Packagist silverstripe/subsites: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/subsites.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cx45-565q-6qx8 (GitHub-reviewed advisory GHSA-cx45-565q-6qx8 lists affected ranges: Packagist silverstripe/subsites >=2.0.0 <2.6.1)

Commands are suggestions: review each one before running it.

Loading voting…