Powerline Gitstatus vulnerable to arbitrary code execution
CVE-2022-42906GHSA-w67g-6gjv-c599
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (powerline-gitstatus 1.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI powerline-gitstatus
- Affected
- < 1.3.2
- Fixed in
- 1.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w67g-6gjv-c599 lists affected ranges: PyPI powerline-gitstatus >=0 <1.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w67g-6gjv-c599 lists affected ranges: PyPI powerline-gitstatus >=0 <1.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-42906: 0.48% estimated exploitation activity in the next 30 days; percentile 41.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
powerline-gitstatus (aka Powerline Gitstatus) before 1.3.2 allows arbitrary code execution. git repositories can contain per-repository configuration that changes the behavior of git, including running arbitrary commands. When using powerline-gitstatus, changing to a directory automatically runs git commands in order to display information about the current repository in the prompt. If an attacker can convince a user to change their current directory to one controlled by the attacker, such as in a shared filesystem or extracted archive, powerline-gitstatus will run arbitrary commands under the attacker's control. NOTE: this is similar to CVE-2022-20001.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w67g-6gjv-c599
- Revision 1 · created ·
Published from osv record GHSA-w67g-6gjv-c599
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-42906 Advisory: Powerline Gitstatus vulnerable to arbitrary code execution IDs: CVE-2022-42906, GHSA-w67g-6gjv-c599 Record: https://patchnext.com/advisories/cve-2022-42906 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: powerline-gitstatus 1.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI powerline-gitstatus: affected < 1.3.2; fixed in 1.3.2 ## Suggested inspection (read-only) - `python -m pip show powerline-gitstatus`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on powerline-gitstatus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w67g-6gjv-c599 (OSV record GHSA-w67g-6gjv-c599 lists affected ranges: PyPI powerline-gitstatus >=0 <1.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-w67g-6gjv-c599 (GitHub-reviewed advisory GHSA-w67g-6gjv-c599 lists affected ranges: PyPI powerline-gitstatus >=0 <1.3.2) Commands are suggestions: review each one before running it.
Loading voting…