Skip to content

← Actionable
Critical, CVSS 9.8

Arbitrary code execution in Apache Commons Text

CVE-2022-42889GHSA-599f-7c49-w659

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven com.guicedee.services:commons-text

    Affected
    <= 1.2.2.1-jre17
    Fixed in
    no fixed version recorded
  • Maven org.apache.commons:commons-text

    Affected
    >= 1.5, < 1.10.0
    Fixed in
    1.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-42889: 99.93% estimated exploitation activity in the next 30 days; percentile 99.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Commons Text performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.text.lookup.StringLookup that performs the interpolation. Starting with version 1.5 and continuing through 1.9, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Text 1.10.0, which disables the problematic…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-599f-7c49-w659

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-42889

Advisory: Arbitrary code execution in Apache Commons Text
IDs: CVE-2022-42889, GHSA-599f-7c49-w659
Record: https://patchnext.com/advisories/cve-2022-42889 (revision 1, source checked 26 Oct 2026, 16:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.commons:commons-text 1.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.guicedee.services:commons-text: affected <= 1.2.2.1-jre17
- Maven org.apache.commons:commons-text: affected >= 1.5, < 1.10.0; fixed in 1.10.0

## Suggested inspection (read-only)
- Maven com.guicedee.services:commons-text: check the installed version with your package manager.
- Maven org.apache.commons:commons-text: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.guicedee.services:commons-text, org.apache.commons:commons-text.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-599f-7c49-w659 (GitHub-reviewed advisory GHSA-599f-7c49-w659 lists affected ranges: Maven org.apache.commons:commons-text >=1.5 =0 <=1.2.2.1-jre17)

Commands are suggestions: review each one before running it.

Loading voting…