Skip to content

← Actionable
Medium, CVSS 6.1

Authenticated OpenRedirect Vulnerability

CVE-2022-41965GHSA-r3qr-vwvg-43f7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opencastproject:opencast-common 12.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-41965: 0.39% estimated exploitation activity in the next 30 days; percentile 33.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Prior to Opencast 12.5 Opencast's Paella authentication page could be used to redirect to an arbitrary URL for authenticated users. Impact The vulnerability allows attackers to redirect users to sites outside of your Opencast install, potentially facilitating phishing attacks or other security issues. Patches This issue is fixed in Opencast 12.5 and newer References Patch fixing the issue If you have any questions or comments about this advisory: Open an issue in our issue tracker Email us at security@opencast.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r3qr-vwvg-43f7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-41965

Advisory: Authenticated OpenRedirect Vulnerability
IDs: CVE-2022-41965, GHSA-r3qr-vwvg-43f7
Record: https://patchnext.com/advisories/cve-2022-41965 (revision 1, source checked 26 Oct 2026, 16:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opencastproject:opencast-common 12.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opencastproject:opencast-common: affected < 12.5; fixed in 12.5

## Suggested inspection (read-only)
- Maven org.opencastproject:opencast-common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opencastproject:opencast-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r3qr-vwvg-43f7 (GitHub-reviewed advisory GHSA-r3qr-vwvg-43f7 lists affected ranges: Maven org.opencastproject:opencast-common >=0 <12.5)

Commands are suggestions: review each one before running it.

Loading voting…