Skip to content

← Actionable
High, CVSS 7.5

muhammara and hummus vulnerable to Unchecked Return Value to NULL Pointer Dereference

CVE-2022-41957GHSA-2r7v-cmch-5x26

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm hummus

    Affected
    every version
    Fixed in
    no fixed version recorded
  • npm muhammara

    Affected
    >= 3.0.0, < 3.4.0< 2.6.2
    Fixed in
    3.4.0, 2.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-41957: 1.15% estimated exploitation activity in the next 30 days; percentile 66.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The package muhammara before 2.6.2, from 3.0.0 and before 3.3.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.

Patches It has been patched in 3.4.0 and has been backported to 2.6.2 There is no patch for hummus, currently

Workarounds Do not process files from untrusted sources or update. Replace hummus with muhammara

References https://github.com/julianhille/MuhammaraJS/pull/235 https://github.com/julianhille/MuhammaraJS/pull/238

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-2r7v-cmch-5x26

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-41957

Advisory: muhammara and hummus vulnerable to Unchecked Return Value to NULL Pointer Dereference
IDs: CVE-2022-41957, GHSA-2r7v-cmch-5x26
Record: https://patchnext.com/advisories/cve-2022-41957 (revision 1, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: muhammara 3.4.0, 2.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm hummus: affected every version
- npm muhammara: affected >= 3.0.0, < 3.4.0; < 2.6.2; fixed in 3.4.0, 2.6.2

## Suggested inspection (read-only)
- `npm ls hummus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls muhammara --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hummus, muhammara.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2r7v-cmch-5x26 (OSV record GHSA-2r7v-cmch-5x26 lists affected ranges: npm hummus >=0; npm muhammara >=3.0.0 =0 <2.6.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…