Creation of new database tables through login form on PostgreSQL
CVE-2022-41932GHSA-4x5r-6v26-7j4v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 14.6-rc-1, 14.4.2, 13.10.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- < 13.10.8>= 14.0.0, < 14.4.2>= 14.5.0, < 14.6-rc-1
- Fixed in
- 14.6-rc-1, 13.10.8, 14.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4x5r-6v26-7j4v lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=0 =14.0.0 =14.5.0 <14.6-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-41932: 0.56% estimated exploitation activity in the next 30 days; percentile 46.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It's possible to make XWiki create many new schemas and fill them with tables just by using a crafted user identifier in the login form. Patches The problem has been patched in XWiki 13.10.8, 14.6RC1 and 14.4.2. Workarounds The only workarounds for this are: use an authenticator which does interpret the login as a reference to a document using a different database than PostgreSQL upgrade XWiki References https://jira.xwiki.org/browse/XWIKI-19886 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki.org Email us at Security Mailing List
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4x5r-6v26-7j4v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41932 Advisory: Creation of new database tables through login form on PostgreSQL IDs: CVE-2022-41932, GHSA-4x5r-6v26-7j4v Record: https://patchnext.com/advisories/cve-2022-41932 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 14.6-rc-1, 14.4.2, 13.10.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected < 13.10.8; >= 14.0.0, < 14.4.2; >= 14.5.0, < 14.6-rc-1; fixed in 14.6-rc-1, 13.10.8, 14.4.2 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4x5r-6v26-7j4v (GitHub-reviewed advisory GHSA-4x5r-6v26-7j4v lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=0 =14.0.0 =14.5.0 <14.6-rc-1) Commands are suggestions: review each one before running it.
Loading voting…