Missing Authorization in User#setDisabledStatus in org.xwiki.platform:xwiki-platform-oldcore
CVE-2022-41929GHSA-2gj2-vj98-j2qq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 14.4.2, 13.10.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- >= 11.7RC1, < 13.10.7>= 14.0.0, < 14.4.2
- Fixed in
- 14.4.2, 13.10.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2gj2-vj98-j2qq lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=11.7RC1 =14.0.0 <14.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2022-41929: 0.79% estimated exploitation activity in the next 30 days; percentile 56.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It's possible for a user with only Script rights to enable or disable a user: this operation should be only doable for users with admin rights. Patches This problem has been patched in XWiki 13.10.7, 14.4.2 and 14.5RC1. Workarounds There is no workaround other than upgrading the wiki, but note that this only impacts users with Script rights: administrator should take care which users have such right. References https://jira.xwiki.org/browse/XWIKI-19804 https://github.com/xwiki/xwiki-platform/commit/0b732f2ef0224e2aaf10e2e1ef48dbd3fb6e10cd For more information If you have any questions or comments about this advisory: Open an issue in JIRA Email us at security ML
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2gj2-vj98-j2qq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41929 Advisory: Missing Authorization in User#setDisabledStatus in org.xwiki.platform:xwiki-platform-oldcore IDs: CVE-2022-41929, GHSA-2gj2-vj98-j2qq Record: https://patchnext.com/advisories/cve-2022-41929 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 14.4.2, 13.10.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 11.7RC1, < 13.10.7; >= 14.0.0, < 14.4.2; fixed in 14.4.2, 13.10.7 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2gj2-vj98-j2qq (GitHub-reviewed advisory GHSA-2gj2-vj98-j2qq lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=11.7RC1 =14.0.0 <14.4.2) Commands are suggestions: review each one before running it.
Loading voting…