Skip to content

← Actionable
Low, CVSS 3.8

Tailscale daemon is vulnerable to information disclosure via CSRF

CVE-2022-41925GHSA-qccm-wmcq-pwr6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tailscale.com/cmd 1.32.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.8 · CVSS:3.0/AV:A/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2022-41925: 0.57% estimated exploitation activity in the next 30 days; percentile 47.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability identified in the Tailscale client allows a malicious website to access the peer API, which can then be used to access Tailscale environment variables. Affected platforms: All Patched Tailscale client versions: v1.32.3 or later, v1.33.257 or later (unstable) What happened? In the Tailscale client, the peer API was vulnerable to DNS rebinding. This allowed an attacker-controlled website visited by the node to rebind DNS for the peer API to an attacker-controlled DNS server, and then making peer API requests in the client, including accessing the node’s Tailscale environment variables. Who is affected? All Tailscale clients prior to version v.1.32.3 are affected. What should I do? Upgrade to v1.32.3 or later to remediate the issue. What is the impact? An attacker with access to the peer API on a node could use that access to read the node’s environment variables, including any credentials or secrets stored in environment variables. This may include Tailscale…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qccm-wmcq-pwr6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-41925

Advisory: Tailscale daemon is vulnerable to information disclosure via CSRF
IDs: CVE-2022-41925, GHSA-qccm-wmcq-pwr6
Record: https://patchnext.com/advisories/cve-2022-41925 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tailscale.com/cmd 1.32.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go tailscale.com/cmd: affected < 1.32.3; fixed in 1.32.3

## Suggested inspection (read-only)
- Go tailscale.com/cmd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tailscale.com/cmd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qccm-wmcq-pwr6 (GitHub-reviewed advisory GHSA-qccm-wmcq-pwr6 lists affected ranges: Go tailscale.com/cmd >=0 <1.32.3)

Commands are suggestions: review each one before running it.

Loading voting…