Fastify: Incorrect Content-Type parsing can lead to CSRF attack
CVE-2022-41919GHSA-3fjj-p79j-c9hh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify 4.10.2, 3.29.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fastify
- Affected
- >= 4.0.0, < 4.10.2>= 3.0.0, < 3.29.4
- Fixed in
- 3.29.4, 4.10.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3fjj-p79j-c9hh lists affected ranges: npm fastify >=4.0.0 =3.0.0 <3.29.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3fjj-p79j-c9hh lists affected ranges: npm fastify >=4.0.0 =3.0.0 <3.29.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2022-41919: 0.41% estimated exploitation activity in the next 30 days; percentile 35.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The attacker can use the incorrect Content-Type to bypass the Pre-Flight checking of fetch. fetch() requests with Content-Type’s essence as "application/x-www-form-urlencoded", "multipart/form-data", or "text/plain", could potentially be used to invoke routes that only accepts application/json content type, thus bypassing any CORS protection, and therefore they could lead to a Cross-Site Request Forgery attack. Patches For 4.x users, please update to at least 4.10.2 For 3.x users, please update to at least 3.29.4 Workarounds Implement Cross-Site Request Forgery protection using @fastify/csrf. References Check out the HackerOne report: https://hackerone.com/reports/1763832. For more information Fastify security policy
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3fjj-p79j-c9hh
- Revision 1 · created ·
Published from osv record GHSA-3fjj-p79j-c9hh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41919 Advisory: Fastify: Incorrect Content-Type parsing can lead to CSRF attack IDs: CVE-2022-41919, GHSA-3fjj-p79j-c9hh Record: https://patchnext.com/advisories/cve-2022-41919 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastify 4.10.2, 3.29.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fastify: affected >= 4.0.0, < 4.10.2; >= 3.0.0, < 3.29.4; fixed in 3.29.4, 4.10.2 ## Suggested inspection (read-only) - `npm ls fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3fjj-p79j-c9hh (OSV record GHSA-3fjj-p79j-c9hh lists affected ranges: npm fastify >=4.0.0 =3.0.0 <3.29.4 (fixed)) - Verified: https://github.com/advisories/GHSA-3fjj-p79j-c9hh (GitHub-reviewed advisory GHSA-3fjj-p79j-c9hh lists affected ranges: npm fastify >=4.0.0 =3.0.0 <3.29.4) Commands are suggestions: review each one before running it.
Loading voting…