Skip to content

← Actionable
Medium, CVSS 4.8amended

CHECK_EQ fail via input in SparseMatrixNNZ

CVE-2022-41901GHSA-g9fm-r5mm-rf9f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.10.1, 2.9.3, 2.8.4; tensorflow-gpu 2.10.1, 2.9.3, 2.8.4; tensorflow-cpu 2.10.1, 2.9.3, 2.8.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1
    Fixed in
    2.10.1, 2.9.3, 2.8.4
  • PyPI tensorflow-gpu

    Affected
    < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1
    Fixed in
    2.10.1, 2.9.3, 2.8.4
  • PyPI tensorflow-cpu

    Affected
    < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1
    Fixed in
    2.10.1, 2.9.3, 2.8.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-41901: 0.49% estimated exploitation activity in the next 30 days; percentile 42.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An input sparsematrix that is not a matrix with a shape with rank 0 will trigger a CHECK fail in tf.rawops.SparseMatrixNNZ. Patches We have patched the issue in GitHub commit f856d02e5322821aad155dad9b3acab1e9f5d693. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by Kang Hong Jin

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g9fm-r5mm-rf9f

  2. Revision 1 · created ·

    Published from osv record GHSA-g9fm-r5mm-rf9f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-41901

Advisory: `CHECK_EQ` fail via input in `SparseMatrixNNZ`
IDs: CVE-2022-41901, GHSA-g9fm-r5mm-rf9f
Record: https://patchnext.com/advisories/cve-2022-41901 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.10.1, 2.9.3, 2.8.4; tensorflow-gpu 2.10.1, 2.9.3, 2.8.4; tensorflow-cpu 2.10.1, 2.9.3, 2.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.8.4; >= 2.9.0, < 2.9.3; >= 2.10.0, < 2.10.1; fixed in 2.10.1, 2.9.3, 2.8.4
- PyPI tensorflow-gpu: affected < 2.8.4; >= 2.9.0, < 2.9.3; >= 2.10.0, < 2.10.1; fixed in 2.10.1, 2.9.3, 2.8.4
- PyPI tensorflow-cpu: affected < 2.8.4; >= 2.9.0, < 2.9.3; >= 2.10.0, < 2.10.1; fixed in 2.10.1, 2.9.3, 2.8.4

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g9fm-r5mm-rf9f (OSV record GHSA-g9fm-r5mm-rf9f lists affected ranges: PyPI tensorflow >=0 =2.9.0 =2.10.0 =0 =2.9.0 =2.10.0 =0 =2.9.0 =2.10.0 <2.10.1 (fixed))
- Verified: https://github.com/advisories/GHSA-g9fm-r5mm-rf9f (GitHub-reviewed advisory GHSA-g9fm-r5mm-rf9f lists affected ranges: PyPI tensorflow >=0 =2.9.0 =2.10.0 =0 =2.9.0 =2.10.0 =0 =2.9.0 =2.10.0 <2.10.1)

Commands are suggestions: review each one before running it.

Loading voting…