Skip to content

← Actionable
High, CVSS 7.1amended

Buffer overflow in CONV_3D_TRANSPOSE on TFLite

CVE-2022-41894GHSA-h6q3-vv32-2cq5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.10.1, 2.9.3, 2.8.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1
    Fixed in
    2.10.1, 2.9.3, 2.8.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-41894: 0.59% estimated exploitation activity in the next 30 days; percentile 48.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The reference kernel of the CONV3DTRANSPOSE TensorFlow Lite operator wrongly increments the dataptr when adding the bias to the result. Instead of dataptr += numchannels; it should be dataptr += outputnumchannels; as if the number of input channels is different than the number of output channels, the wrong result will be returned and a buffer overflow will occur if numchannels outputnumchannels. An attacker can craft a model with a specific number of input channels in a way similar to the attached example script. It is then possible to write specific values through the bias of the layer outside the bounds of the buffer. This attack only works if the reference kernel resolver is used in the interpreter (i.e. experimentalopresolvertype=tf.lite.experimental.OpResolverType.BUILTINREF is used). Patches We have patched the issue in GitHub commit 72c0bdcb25305b0b36842d746cc61d72658d2941. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h6q3-vv32-2cq5

  2. Revision 1 · created ·

    Published from osv record GHSA-h6q3-vv32-2cq5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-41894

Advisory: Buffer overflow in `CONV_3D_TRANSPOSE` on TFLite
IDs: CVE-2022-41894, GHSA-h6q3-vv32-2cq5
Record: https://patchnext.com/advisories/cve-2022-41894 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.10.1, 2.9.3, 2.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.8.4; >= 2.9.0, < 2.9.3; >= 2.10.0, < 2.10.1; fixed in 2.10.1, 2.9.3, 2.8.4

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h6q3-vv32-2cq5 (OSV record GHSA-h6q3-vv32-2cq5 lists affected ranges: PyPI tensorflow >=0 =2.9.0 =2.10.0 <2.10.1 (fixed))
- Verified: https://github.com/advisories/GHSA-h6q3-vv32-2cq5 (GitHub-reviewed advisory GHSA-h6q3-vv32-2cq5 lists affected ranges: PyPI tensorflow >=0 =2.9.0 =2.10.0 <2.10.1)

Commands are suggestions: review each one before running it.

Loading voting…