HAProxyMessageDecoder Stack Exhaustion DoS
CVE-2022-41881GHSA-fx2c-96vj-985v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-haproxy 4.1.86.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-codec-haproxy
- Affected
- < 4.1.86.Final
- Fixed in
- 4.1.86.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fx2c-96vj-985v lists affected ranges: Maven io.netty:netty-codec-haproxy >=0 <4.1.86.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2022-41881: 1.58% estimated exploitation activity in the next 30 days; percentile 75.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. Patches Users should upgrade to 4.1.86.Final. Workarounds There is no workaround, except using a custom HaProxyMessageDecoder. References When parsing a TLV with type = PP2TYPESSL, the value can be again a TLV with type = PP2TYPESSL and so on. The only limitation of the recursion is that the TLV length cannot be bigger than 0xffff because it is encoded in an unsigned short type. Providing a TLV with a nesting level that is large enough will lead to raising of a StackOverflowError. The StackOverflowError will be caught if HAProxyMessageDecoder is used as part of Netty’s ChannelPipeline, but using it directly without the ChannelPipeline will lead to a thrown exception / crash. For more information If you have any questions or comments about this advisory: Open an issue in netty
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fx2c-96vj-985v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41881 Advisory: HAProxyMessageDecoder Stack Exhaustion DoS IDs: CVE-2022-41881, GHSA-fx2c-96vj-985v Record: https://patchnext.com/advisories/cve-2022-41881 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-haproxy 4.1.86.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-codec-haproxy: affected < 4.1.86.Final; fixed in 4.1.86.Final ## Suggested inspection (read-only) - Maven io.netty:netty-codec-haproxy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-codec-haproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fx2c-96vj-985v (GitHub-reviewed advisory GHSA-fx2c-96vj-985v lists affected ranges: Maven io.netty:netty-codec-haproxy >=0 <4.1.86.Final) Commands are suggestions: review each one before running it.
Loading voting…