Skip to content

← Actionable
High, CVSS 7.2amended

Parse Server vulnerable to Prototype Pollution via Cloud Code Webhooks or Cloud Code Triggers

CVE-2022-41878GHSA-xprv-wvh7-qqqx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 5.3.2, 4.10.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 4.10.19>= 5.0.0, < 5.3.2
    Fixed in
    5.3.2, 4.10.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-41878: 0.95% estimated exploitation activity in the next 30 days; percentile 61.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Keywords that are specified in the Parse Server option requestKeywordDenylist can be injected via Cloud Code Webhooks or Triggers. This will result in the keyword being saved to the database, bypassing the requestKeywordDenylist option. Patches Improved keyword detection. Workarounds Configure your firewall to only allow trusted servers to make request to the Parse Server Cloud Code Webhooks API, or block the API completely if you are not using the feature. Collaborators Mikhail Shcherbakov, Cristian-Alexandru Staicu and Musard Balliu working with Trend Micro Zero Day Initiative References - https://github.com/parse-community/parse-server/security/advisories/GHSA-xprv-wvh7-qqqx

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xprv-wvh7-qqqx

  2. Revision 1 · created ·

    Published from osv record GHSA-xprv-wvh7-qqqx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-41878

Advisory: Parse Server vulnerable to Prototype Pollution via Cloud Code Webhooks or Cloud Code Triggers
IDs: CVE-2022-41878, GHSA-xprv-wvh7-qqqx
Record: https://patchnext.com/advisories/cve-2022-41878 (revision 2, source checked 26 Oct 2026, 12:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 5.3.2, 4.10.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 4.10.19; >= 5.0.0, < 5.3.2; fixed in 5.3.2, 4.10.19

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xprv-wvh7-qqqx (OSV record GHSA-xprv-wvh7-qqqx lists affected ranges: npm parse-server >=0 =5.0.0 <5.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-xprv-wvh7-qqqx (GitHub-reviewed advisory GHSA-xprv-wvh7-qqqx lists affected ranges: npm parse-server >=0 =5.0.0 <5.3.2)

Commands are suggestions: review each one before running it.

Loading voting…