Tauri Filesystem Scope can be Partially Bypassed
CVE-2022-41874GHSA-q9wv-22m9-vhqh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (Tauri 1.1.2, 1.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io Tauri
- Affected
- >= 1.0.0, < 1.0.7>= 1.1.0, < 1.1.2
- Fixed in
- 1.1.2, 1.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q9wv-22m9-vhqh lists affected ranges: crates.io Tauri >=1.0.0 =1.1.0 <1.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.3 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
- EPSS
- CVE-2022-41874: 0.46% estimated exploitation activity in the next 30 days; percentile 40.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to incorrect escaping of special characters in paths selected via the file dialog and drag and drop functionality, it was possible to partially bypass the fs scope definition. It was not possible to traverse into arbitrary paths, as the issue was limited to neighboring files and sub folders of already allowed paths. The impact differs on Windows, MacOS and Linux due to different specifications of valid path characters. On Linux or MacOS based systems it was possible to use the , and [a-Z] patterns inside a path, which allowed to read the content of sub directories and single character files in a folder, where only specific files or the directory itself were allowed. On Windows [a-Z] was the possible bypass pattern, as is not treated as a valid path component. This implies that only single character files inside an already allowed directory were unintentionally accessible. This bypass depends on the file picker dialog or dragged files, as user selected paths are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q9wv-22m9-vhqh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41874 Advisory: Tauri Filesystem Scope can be Partially Bypassed IDs: CVE-2022-41874, GHSA-q9wv-22m9-vhqh Record: https://patchnext.com/advisories/cve-2022-41874 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: Tauri 1.1.2, 1.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io Tauri: affected >= 1.0.0, < 1.0.7; >= 1.1.0, < 1.1.2; fixed in 1.1.2, 1.0.7 ## Suggested inspection (read-only) - crates.io Tauri: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on Tauri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q9wv-22m9-vhqh (GitHub-reviewed advisory GHSA-q9wv-22m9-vhqh lists affected ranges: crates.io Tauri >=1.0.0 =1.1.0 <1.1.2) Commands are suggestions: review each one before running it.
Loading voting…