Skip to content

← Actionable
Medium, CVSS 5.3amended

nadesiko3 allows remote attacker to inject invalid value to decodeURIComponent of nako3edit

CVE-2022-41777GHSA-x2jx-w3wm-9p3p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nadesiko3 3.3.75), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2022-41777: 1.60% estimated exploitation activity in the next 30 days; percentile 75.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Nako3edit is the editor component of Nadeshiko 3, a programming language developed based on Japanese. Improper check or handling of exceptional conditions in Nako3edit v3.3.74 and earlier allows a remote attacker to inject an invalid value to decodeURIComponent of nako3edit, which may lead the server to crash.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x2jx-w3wm-9p3p

  2. Revision 1 · created ·

    Published from osv record GHSA-x2jx-w3wm-9p3p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-41777

Advisory: nadesiko3 allows remote attacker to inject invalid value to decodeURIComponent of nako3edit
IDs: CVE-2022-41777, GHSA-x2jx-w3wm-9p3p
Record: https://patchnext.com/advisories/cve-2022-41777 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nadesiko3 3.3.75. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nadesiko3: affected < 3.3.75; fixed in 3.3.75

## Suggested inspection (read-only)
- `npm ls nadesiko3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nadesiko3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x2jx-w3wm-9p3p (OSV record GHSA-x2jx-w3wm-9p3p lists affected ranges: npm nadesiko3 >=0 <3.3.75 (fixed))
- Verified: https://github.com/advisories/GHSA-x2jx-w3wm-9p3p (GitHub-reviewed advisory GHSA-x2jx-w3wm-9p3p lists affected ranges: npm nadesiko3 >=0 <3.3.75)

Commands are suggestions: review each one before running it.

Loading voting…